change version to 1.0.2-2
[python-simplemediawiki.debian] / debian / patches / 0007-use-setuptools-if-available.patch
1 From b1031465666db28694e2eb69c81d9ce33857f09a Mon Sep 17 00:00:00 2001
2 From: Benjamin Mako Hill <mako@atdot.cc>
3 Date: Mon, 9 Apr 2012 18:13:37 -0400
4 Subject: use setuptools if available
5
6 ---
7  setup.py |    8 ++++++--
8  1 files changed, 6 insertions(+), 2 deletions(-)
9
10 diff --git a/setup.py b/setup.py
11 index 79a2b1e..fb1768e 100644
12 --- a/setup.py
13 +++ b/setup.py
14 @@ -1,4 +1,8 @@
15 -from distutils.core import setup
16 +try:
17 +    from setuptools import setup
18 +except ImportError:
19 +    from distutils.core import setup
20 +
21  setup(name='simplemediawiki',
22        version='1.0.2',
23        description='Extremely low-level wrapper to the MediaWiki API',
24 @@ -11,7 +15,7 @@ setup(name='simplemediawiki',
25            'License :: OSI Approved :: GNU Library or Lesser General Public '
26            'License (LGPL)',
27        ],
28 -      requires=[
29 +      install_requires=[
30            'iso8601',
31        ],
32        py_modules=['simplemediawiki'])

Benjamin Mako Hill || Want to submit a patch?