merge patched into master
[python-simplemediawiki.debian] / debian / patches / 0002-Import-iso8601-in-a-way-that-makes-pylint-happy.patch
diff --git a/debian/patches/0002-Import-iso8601-in-a-way-that-makes-pylint-happy.patch b/debian/patches/0002-Import-iso8601-in-a-way-that-makes-pylint-happy.patch
new file mode 100644 (file)
index 0000000..5c55bcb
--- /dev/null
@@ -0,0 +1,25 @@
+From 9ce74c8ebc5ac8ee818ec122c89531b1d1b4c9ac Mon Sep 17 00:00:00 2001
+From: Ian Weller <ian@ianweller.org>
+Date: Fri, 4 Feb 2011 22:10:54 -0600
+Subject: Import iso8601 in a way that makes pylint happy
+
+---
+ simplemediawiki.py |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/simplemediawiki.py b/simplemediawiki.py
+index 6bdd944..ff879ed 100644
+--- a/simplemediawiki.py
++++ b/simplemediawiki.py
+@@ -33,7 +33,7 @@ of namespaces are provided for your convenience.
+ import cookielib
+ import gzip
+-from iso8601 import iso8601
++import iso8601.iso8601 as iso8601
+ import json
+ from StringIO import StringIO
+ import urllib
+-- 
+1.7.2.3
+

Benjamin Mako Hill || Want to submit a patch?