merge patched into master
[python-simplemediawiki.debian] / debian / patches / 0001-Fix-not-being-able-to-import-the-module.patch
diff --git a/debian/patches/0001-Fix-not-being-able-to-import-the-module.patch b/debian/patches/0001-Fix-not-being-able-to-import-the-module.patch
new file mode 100644 (file)
index 0000000..8154aef
--- /dev/null
@@ -0,0 +1,40 @@
+From a54cc1e6cdfacf678711f6c88021c8eca5c6580c Mon Sep 17 00:00:00 2001
+From: Ian Weller <ian@ianweller.org>
+Date: Fri, 4 Feb 2011 22:06:35 -0600
+Subject: Fix not being able to import the module
+
+---
+ simplemediawiki.py |   13 ++++++-------
+ 1 files changed, 6 insertions(+), 7 deletions(-)
+
+diff --git a/simplemediawiki.py b/simplemediawiki.py
+index ab0f3f7..6bdd944 100644
+--- a/simplemediawiki.py
++++ b/simplemediawiki.py
+@@ -39,6 +39,12 @@ from StringIO import StringIO
+ import urllib
+ import urllib2
++__author__ = 'Ian Weller <ian@ianweller.org>'
++__version__ = '1.0.2'
++DEFAULT_UA = ('python-simplemediawiki/%s '
++              '+https://github.com/ianweller/python-simplemediawiki') \
++        % __version__
++
+ class MediaWiki():
+     """
+@@ -206,10 +212,3 @@ class MediaWiki():
+         objects.
+         """
+         return iso8601.parse_date(date)
+-
+-
+-__author__ = 'Ian Weller <ian@ianweller.org>'
+-__version__ = '1.0.2'
+-DEFAULT_UA = 'python-simplemediawiki/%s ' + \
+-        '+https://github.com/ianweller/python-simplemediawiki' \
+-        % __version__
+-- 
+1.7.2.3
+

Benjamin Mako Hill || Want to submit a patch?