merge patched into master
[python-simplemediawiki.debian] / debian / patches / 0005-Add-docstring-to-_fetch_http.patch
1 From bed00dea090ba51e33981e0b6784f23253d4f74a Mon Sep 17 00:00:00 2001
2 From: Ian Weller <ian@ianweller.org>
3 Date: Sat, 5 Feb 2011 00:00:46 -0600
4 Subject: Add docstring to _fetch_http
5
6 ---
7  simplemediawiki.py |    4 ++++
8  1 files changed, 4 insertions(+), 0 deletions(-)
9
10 diff --git a/simplemediawiki.py b/simplemediawiki.py
11 index f039c5a..2934ab9 100644
12 --- a/simplemediawiki.py
13 +++ b/simplemediawiki.py
14 @@ -74,6 +74,10 @@ class MediaWiki():
15          self._opener.addheaders = [('User-agent', user_agent)]
16  
17      def _fetch_http(self, url, params):
18 +        """
19 +        Standard HTTP request handler for this class with gzip and cookie
20 +        support.
21 +        """
22          request = urllib2.Request(url, urllib.urlencode(params))
23          request.add_header('Accept-encoding', 'gzip')
24          response = self._opener.open(request)
25 -- 
26 1.7.2.3
27

Benjamin Mako Hill || Want to submit a patch?